summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 7272cc6..50d302d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -148,6 +148,27 @@
148 self.nixosModules.profiles.server 148 self.nixosModules.profiles.server
149 ]; 149 ];
150 }; 150 };
151
152 iso = nixpkgs.lib.nixosSystem {
153 system = "x86_64-linux";
154 modules = [
155 self.nixosModules.default
156 ({ modulesPath, ... }: {
157 imports = [
158 (modulesPath + "/installer/cd-dvd/iso-image.nix")
159 ];
160
161 isoImage.makeEfiBootable = true;
162 isoImage.makeUsbBootable = true;
163
164 home-manager.users.minijackson.home.stateVersion = "21.05";
165 home-manager.users.root.home.stateVersion = "21.05";
166
167 users.users.minijackson.initialHashedPassword = "";
168 users.users.root.initialHashedPassword = "";
169 })
170 ];
171 };
151 }; 172 };
152 173
153 hydraJobs = 174 hydraJobs =
@@ -243,6 +264,7 @@
243 ''; 264 '';
244 }; 265 };
245 266
267 isoImage.x86_64-linux = self.nixosConfigurations.iso.config.system.build.isoImage;
246 }; 268 };
247 269
248 }; 270 };