diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 21 |
1 files changed, 14 insertions, 7 deletions
@@ -1,14 +1,17 @@ | |||
1 | { | 1 | { |
2 | description = "My NixOS configurations"; | 2 | description = "My NixOS configurations"; |
3 | 3 | ||
4 | inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.05"; | 4 | inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.11"; |
5 | inputs.nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixos-unstable"; | 5 | inputs.nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixos-unstable"; |
6 | inputs.flake-utils.url = "github:numtide/flake-utils"; | 6 | inputs.flake-utils.url = "github:numtide/flake-utils"; |
7 | inputs.home-manager = { | 7 | inputs.home-manager = { |
8 | url = "github:nix-community/home-manager/release-22.05"; | 8 | url = "github:nix-community/home-manager/release-22.11"; |
9 | inputs.nixpkgs.follows = "nixpkgs"; | 9 | inputs.nixpkgs.follows = "nixpkgs"; |
10 | }; | 10 | }; |
11 | inputs.nur.url = "github:nix-community/NUR"; | 11 | inputs.rycee-nur = { |
12 | url = "gitlab:rycee/nur-expressions"; | ||
13 | flake = false; | ||
14 | }; | ||
12 | inputs.musnix = { | 15 | inputs.musnix = { |
13 | url = "github:musnix/musnix"; | 16 | url = "github:musnix/musnix"; |
14 | flake = false; | 17 | flake = false; |
@@ -33,8 +36,8 @@ | |||
33 | test = { config, ... }: { | 36 | test = { config, ... }: { |
34 | imports = [ self.nixosModules.default ]; | 37 | imports = [ self.nixosModules.default ]; |
35 | 38 | ||
36 | home-manager.users.minijackson.home.stateVersion = "21.05"; | 39 | home-manager.users.minijackson.home.stateVersion = "22.11"; |
37 | home-manager.users.root.home.stateVersion = "21.05"; | 40 | home-manager.users.root.home.stateVersion = "22.11"; |
38 | 41 | ||
39 | users.users.minijackson.initialHashedPassword = ""; | 42 | users.users.minijackson.initialHashedPassword = ""; |
40 | users.users.root.initialHashedPassword = ""; | 43 | users.users.root.initialHashedPassword = ""; |
@@ -141,6 +144,7 @@ | |||
141 | { | 144 | { |
142 | 145 | ||
143 | tests.testDefault = nixosTest { | 146 | tests.testDefault = nixosTest { |
147 | name = "default"; | ||
144 | nodes.machine = self.nixosModules.test; | 148 | nodes.machine = self.nixosModules.test; |
145 | testScript = '' | 149 | testScript = '' |
146 | # TODO | 150 | # TODO |
@@ -149,6 +153,7 @@ | |||
149 | }; | 153 | }; |
150 | 154 | ||
151 | tests.testPlainDesktop = nixosTest { | 155 | tests.testPlainDesktop = nixosTest { |
156 | name = "plainDesktop"; | ||
152 | nodes.machine = { ... }: { | 157 | nodes.machine = { ... }: { |
153 | imports = [ | 158 | imports = [ |
154 | self.nixosModules.test | 159 | self.nixosModules.test |
@@ -163,6 +168,7 @@ | |||
163 | }; | 168 | }; |
164 | 169 | ||
165 | tests.testFullDesktop = nixosTest { | 170 | tests.testFullDesktop = nixosTest { |
171 | name = "fullDesktop"; | ||
166 | nodes.machine = { ... }: { | 172 | nodes.machine = { ... }: { |
167 | imports = [ | 173 | imports = [ |
168 | self.nixosModules.test | 174 | self.nixosModules.test |
@@ -187,6 +193,7 @@ | |||
187 | }; | 193 | }; |
188 | 194 | ||
189 | tests.testServer = nixosTest { | 195 | tests.testServer = nixosTest { |
196 | name = "server"; | ||
190 | nodes.machine = { ... }: { | 197 | nodes.machine = { ... }: { |
191 | imports = [ | 198 | imports = [ |
192 | self.nixosModules.test | 199 | self.nixosModules.test |
@@ -251,8 +258,8 @@ | |||
251 | isoImage.makeEfiBootable = true; | 258 | isoImage.makeEfiBootable = true; |
252 | isoImage.makeUsbBootable = true; | 259 | isoImage.makeUsbBootable = true; |
253 | 260 | ||
254 | home-manager.users.minijackson.home.stateVersion = "21.05"; | 261 | home-manager.users.minijackson.home.stateVersion = "22.11"; |
255 | home-manager.users.root.home.stateVersion = "21.05"; | 262 | home-manager.users.root.home.stateVersion = "22.11"; |
256 | 263 | ||
257 | users.users.minijackson.initialHashedPassword = ""; | 264 | users.users.minijackson.initialHashedPassword = ""; |
258 | users.users.root.initialHashedPassword = ""; | 265 | users.users.root.initialHashedPassword = ""; |