diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -141,7 +141,7 @@ | |||
141 | { | 141 | { |
142 | 142 | ||
143 | tests.testDefault = nixosTest { | 143 | tests.testDefault = nixosTest { |
144 | machine = self.nixosModules.test; | 144 | nodes.machine = self.nixosModules.test; |
145 | testScript = '' | 145 | testScript = '' |
146 | # TODO | 146 | # TODO |
147 | machine.wait_for_unit("multi-user.target") | 147 | machine.wait_for_unit("multi-user.target") |
@@ -149,7 +149,7 @@ | |||
149 | }; | 149 | }; |
150 | 150 | ||
151 | tests.testPlainDesktop = nixosTest { | 151 | tests.testPlainDesktop = nixosTest { |
152 | machine = { ... }: { | 152 | nodes.machine = { ... }: { |
153 | imports = [ | 153 | imports = [ |
154 | self.nixosModules.test | 154 | self.nixosModules.test |
155 | self.nixosModules.profiles.desktop | 155 | self.nixosModules.profiles.desktop |
@@ -163,7 +163,7 @@ | |||
163 | }; | 163 | }; |
164 | 164 | ||
165 | tests.testFullDesktop = nixosTest { | 165 | tests.testFullDesktop = nixosTest { |
166 | machine = { ... }: { | 166 | nodes.machine = { ... }: { |
167 | imports = [ | 167 | imports = [ |
168 | self.nixosModules.test | 168 | self.nixosModules.test |
169 | self.nixosModules.profiles.desktop | 169 | self.nixosModules.profiles.desktop |
@@ -187,7 +187,7 @@ | |||
187 | }; | 187 | }; |
188 | 188 | ||
189 | tests.testServer = nixosTest { | 189 | tests.testServer = nixosTest { |
190 | machine = { ... }: { | 190 | nodes.machine = { ... }: { |
191 | imports = [ | 191 | imports = [ |
192 | self.nixosModules.test | 192 | self.nixosModules.test |
193 | self.nixosModules.profiles.server | 193 | self.nixosModules.profiles.server |