summaryrefslogtreecommitdiffstats
path: root/common/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/vim.nix')
-rw-r--r--common/vim.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/common/vim.nix b/common/vim.nix
index acbdc36..8f28699 100644
--- a/common/vim.nix
+++ b/common/vim.nix
@@ -4,12 +4,10 @@ inputs: {
4 lib, 4 lib,
5 ... 5 ...
6}: let 6}: let
7 inherit (pkgs.unstable) vimPlugins wrapNeovim; 7 inherit (pkgs.unstable) neovim-unwrapped vimPlugins wrapNeovim;
8 8
9 luaFormat = inputs.self.lib.generators.lua {}; 9 luaFormat = inputs.self.lib.generators.lua {};
10 10
11 neovim-unwrapped = pkgs.unstable.neovim-unwrapped;
12
13 cfg = config.vim; 11 cfg = config.vim;
14 12
15 variables = with lib; 13 variables = with lib;
@@ -178,9 +176,7 @@ in {
178 }; 176 };
179 }; 177 };
180 178
181 environment.systemPackages = with pkgs.unstable; [ 179 environment.systemPackages = [myNeovim];
182 myNeovim
183 ];
184 180
185 environment.variables = { 181 environment.variables = {
186 EDITOR = "nvim"; 182 EDITOR = "nvim";