summaryrefslogtreecommitdiffstats
path: root/common/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/vim.nix')
-rw-r--r--common/vim.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/common/vim.nix b/common/vim.nix
index ade66e1..ec21e75 100644
--- a/common/vim.nix
+++ b/common/vim.nix
@@ -36,7 +36,7 @@ let
36 inherit (config.vim) beforePlugins; 36 inherit (config.vim) beforePlugins;
37 37
38 customRC = '' 38 customRC = ''
39 autocmd VimEnter * lua require("myConfig") 39 lua require("myConfig")
40 40
41 ${cfg.extraConfig} 41 ${cfg.extraConfig}
42 ''; 42 '';
@@ -58,6 +58,8 @@ let
58 lsp-status-nvim 58 lsp-status-nvim
59 59
60 nvim-compe 60 nvim-compe
61 compe-latex-symbols
62 compe-zsh
61 63
62 vim-vsnip 64 vim-vsnip
63 vim-vsnip-integ 65 vim-vsnip-integ
@@ -69,6 +71,8 @@ let
69 nvim-treesitter-textobjects 71 nvim-treesitter-textobjects
70 nvim-treesitter-context 72 nvim-treesitter-context
71 73
74 vim-matchup
75
72 # Motions 76 # Motions
73 camelcasemotion 77 camelcasemotion
74 surround 78 surround