summaryrefslogtreecommitdiffstats
path: root/common/nixvim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/nixvim.nix')
-rw-r--r--common/nixvim.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/common/nixvim.nix b/common/nixvim.nix
index 367f442..72a80e2 100644
--- a/common/nixvim.nix
+++ b/common/nixvim.nix
@@ -307,6 +307,46 @@ inputs:
307 ]; 307 ];
308 308
309 plugins = { 309 plugins = {
310 cmp = {
311 enable = true;
312 autoEnableSources = false;
313 settings = {
314 mapping.__raw = ''
315 cmp.mapping.preset.insert({
316 ['<CR>'] = cmp.mapping.confirm({ select = false }),
317 })
318 '';
319
320 sources.__raw = ''
321 cmp.config.sources({
322 { name = 'orgmode' },
323 { name = 'git' },
324 { name = 'nvim_lsp' },
325 { name = 'async_path' },
326 }, {
327 { name = 'buffer' },
328 }, {
329 { name = 'spell' },
330 })
331 '';
332 };
333 };
334 cmp-nvim-lsp.enable = true;
335 cmp-async-path.enable = true;
336 cmp-buffer.enable = true;
337 cmp-git = {
338 enable = true;
339 settings = {
340 filetypes = [
341 "gitcommit"
342 "octo"
343 "NeogitCommitMessage"
344 "jjdescription"
345 ];
346 };
347 };
348 cmp-spell.enable = true;
349
310 diffview.enable = true; 350 diffview.enable = true;
311 351
312 dressing.enable = true; 352 dressing.enable = true;