summaryrefslogtreecommitdiffstats
path: root/common/commandline/tmux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/commandline/tmux.nix')
-rw-r--r--common/commandline/tmux.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/common/commandline/tmux.nix b/common/commandline/tmux.nix
index b355662..72c918c 100644
--- a/common/commandline/tmux.nix
+++ b/common/commandline/tmux.nix
@@ -21,7 +21,7 @@ in {
21 terminal = "tmux-256color"; 21 terminal = "tmux-256color";
22 historyLimit = 50000; 22 historyLimit = 50000;
23 23
24 plugins = with pkgs.tmuxPlugins; [copycat sensible urlview]; 24 plugins = with pkgs.tmuxPlugins; [tmux-thumbs sensible urlview];
25 25
26 extraConfig = with config.theme; '' 26 extraConfig = with config.theme; ''
27 bind-key R run-shell ' \ 27 bind-key R run-shell ' \
@@ -38,6 +38,9 @@ in {
38 # Add plugin here because it needs its configuration 38 # Add plugin here because it needs its configuration
39 run-shell '${pkgs.tmuxPlugins.prefix-highlight}/share/tmux-plugins/prefix-highlight/prefix_highlight.tmux' 39 run-shell '${pkgs.tmuxPlugins.prefix-highlight}/share/tmux-plugins/prefix-highlight/prefix_highlight.tmux'
40 40
41 # Tmux Thumbs
42 set -g @thumbs-alphabet dvorak
43
41 # Be faster switching windows 44 # Be faster switching windows
42 bind C-n next-window 45 bind C-n next-window
43 bind C-p previous-window 46 bind C-p previous-window