summaryrefslogtreecommitdiffstats
path: root/common/commandline/starship.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/commandline/starship.nix')
-rw-r--r--common/commandline/starship.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/common/commandline/starship.nix b/common/commandline/starship.nix
new file mode 100644
index 0000000..1683765
--- /dev/null
+++ b/common/commandline/starship.nix
@@ -0,0 +1,26 @@
1inputs: {lib, ...}: {
2 home-manager.users.minijackson = {
3 programs.starship = {
4 enable = true;
5 enableZshIntegration = false;
6
7 settings = lib.mkMerge [
8 {
9 directory = {
10 fish_style_pwd_dir_length = 2;
11 style = "bold blue";
12 };
13 jobs.symbol = "+ ";
14 nix_shell.style = "bold blue";
15 package = {
16 disabled = true;
17 style = "bold green";
18 };
19 rust.style = "bold dimmed yellow";
20 }
21
22 (lib.importTOML ./starship-plain-text-symbols.toml)
23 ];
24 };
25 };
26}