summaryrefslogtreecommitdiffstats
path: root/common/commandline/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/commandline/git.nix')
-rw-r--r--common/commandline/git.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/common/commandline/git.nix b/common/commandline/git.nix
index 8ccb528..fb9bed2 100644
--- a/common/commandline/git.nix
+++ b/common/commandline/git.nix
@@ -3,7 +3,14 @@ inputs:
3{ config, pkgs, lib, ... }: 3{ config, pkgs, lib, ... }:
4 4
5{ 5{
6 # TODO: add signing 6 users.users.minijackson.packages = [pkgs.git-branchless];
7
8 environment.shellAliases.git = "git-branchless wrap --";
9
10 programs.zsh.interactiveShellInit = ''
11 source ${../../dotfiles/git-branchless.zsh}
12 '';
13
7 home-manager.users.minijackson = { ... }: { 14 home-manager.users.minijackson = { ... }: {
8 programs.git = { 15 programs.git = {
9 enable = true; 16 enable = true;
@@ -68,6 +75,7 @@ inputs:
68 }; 75 };
69 }; 76 };
70 77
78 # TODO: move common to NixOS' programs.git.config
71 home-manager.users.root = { ... }: { 79 home-manager.users.root = { ... }: {
72 programs.git = with lib; 80 programs.git = with lib;
73 mkMerge [ 81 mkMerge [