diff options
author | Minijackson <minijackson@riseup.net> | 2025-03-14 08:38:05 +0100 |
---|---|---|
committer | Minijackson <minijackson@riseup.net> | 2025-03-14 08:53:23 +0100 |
commit | 0369d277a8959f6064a93354b03c45f5cf59a03d (patch) | |
tree | 8ea3a248d07cd08bf89a109d94f30f6def2cb28e /usecases/desktop/graphical/greetd.nix | |
parent | cbfe664b596cf94266b93013a214cd134d7fb8f0 (diff) | |
download | nixos-config-reborn-0369d277a8959f6064a93354b03c45f5cf59a03d.tar.gz nixos-config-reborn-0369d277a8959f6064a93354b03c45f5cf59a03d.zip |
graphical: factorize sway components in other modules
Diffstat (limited to 'usecases/desktop/graphical/greetd.nix')
-rw-r--r-- | usecases/desktop/graphical/greetd.nix | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/usecases/desktop/graphical/greetd.nix b/usecases/desktop/graphical/greetd.nix new file mode 100644 index 0000000..615b3b5 --- /dev/null +++ b/usecases/desktop/graphical/greetd.nix | |||
@@ -0,0 +1,29 @@ | |||
1 | { | ||
2 | config, | ||
3 | pkgs, | ||
4 | lib, | ||
5 | ... | ||
6 | }: | ||
7 | let | ||
8 | cfg = config.reborn.greetd; | ||
9 | in | ||
10 | { | ||
11 | options.reborn.greetd = { | ||
12 | enable = lib.mkEnableOption "Reborn greetd config"; | ||
13 | |||
14 | command = lib.mkOption { | ||
15 | description = "Default session command"; | ||
16 | type = lib.types.str; | ||
17 | default = "sway"; | ||
18 | }; | ||
19 | }; | ||
20 | |||
21 | config = lib.mkIf cfg.enable { | ||
22 | services.greetd = { | ||
23 | enable = true; | ||
24 | vt = 6; | ||
25 | settings.default_session.command = "${pkgs.greetd.tuigreet}/bin/tuigreet --time --cmd ${cfg.command}"; | ||
26 | }; | ||
27 | |||
28 | }; | ||
29 | } | ||