summaryrefslogtreecommitdiffstats
path: root/common/nix.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2021-04-18 16:58:23 +0200
committerMinijackson <minijackson@riseup.net>2021-04-18 16:58:23 +0200
commit8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b (patch)
treecd0de6a4642b76b42002dae5291c307d30727bc6 /common/nix.nix
parent46ac3d5464712d6b0e0bee4ac62543abcbf2db2c (diff)
downloadnixos-config-reborn-8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b.tar.gz
nixos-config-reborn-8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b.zip
revamp with nix flakes + desktop config
Diffstat (limited to 'common/nix.nix')
-rw-r--r--common/nix.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/common/nix.nix b/common/nix.nix
new file mode 100644
index 0000000..f16e1d9
--- /dev/null
+++ b/common/nix.nix
@@ -0,0 +1,19 @@
1inputs:
2
3{ pkgs, ... }:
4
5{
6 nix = {
7 autoOptimiseStore = true;
8 gc = {
9 automatic = true;
10 dates = "03:15";
11 options = "--delete-older-than 30d";
12 };
13
14 package = pkgs.nixFlakes;
15 extraOptions = ''
16 experimental-features = nix-command flakes
17 '';
18 };
19}