summaryrefslogtreecommitdiffstats
path: root/common/commandline/zsh.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2023-08-18 21:19:19 +0200
committerMinijackson <minijackson@riseup.net>2023-08-18 21:19:19 +0200
commit9990269b75c47ce0f095e621c011f48e7667544c (patch)
treed97a718ff9b2fd0086bd80602a3bcf4d6fdb6642 /common/commandline/zsh.nix
parent360fb529f339f7a2fe60a132387aad69064f662d (diff)
downloadnixos-config-reborn-9990269b75c47ce0f095e621c011f48e7667544c.tar.gz
nixos-config-reborn-9990269b75c47ce0f095e621c011f48e7667544c.zip
zsh: follow XDG dirs
Diffstat (limited to 'common/commandline/zsh.nix')
-rw-r--r--common/commandline/zsh.nix34
1 files changed, 16 insertions, 18 deletions
diff --git a/common/commandline/zsh.nix b/common/commandline/zsh.nix
index 2fc8c87..1110bf2 100644
--- a/common/commandline/zsh.nix
+++ b/common/commandline/zsh.nix
@@ -60,27 +60,25 @@ in
60 60
61 users.defaultUserShell = pkgs.zsh; 61 users.defaultUserShell = pkgs.zsh;
62 62
63 home-manager.users = 63 home-manager.sharedModules = [
64 let 64 ({config, ...}: {
65 config = { 65 programs.zsh = {
66 enable = true; 66 enable = true;
67 # Completion is already handled by the GRML conf 67 # Completion is already handled by the GRML conf
68 enableCompletion = false; 68 enableCompletion = false;
69 69
70 plugins = [{ 70 # XDG
71 name = "shmart-prompt-dir"; 71 dotDir = ".config/zsh";
72 src = inputs.shmart-prompt-dir; 72 history.path = "${config.xdg.dataHome}/zsh/zsh_history";
73 file = "none"; 73
74 }]; 74 plugins = [
75 }; 75 {
76 in 76 name = "shmart-prompt-dir";
77 { 77 src = inputs.shmart-prompt-dir;
78 minijackson = { ... }: { 78 file = "none";
79 # Allows zsh config from home-manager 79 }
80 programs.zsh = config; 80 ];
81 };
82 root = { ... }: {
83 programs.zsh = config;
84 }; 81 };
85 }; 82 })
83 ];
86} 84}