diff options
author | Minijackson <minijackson@riseup.net> | 2021-04-18 16:58:23 +0200 |
---|---|---|
committer | Minijackson <minijackson@riseup.net> | 2021-04-18 16:58:23 +0200 |
commit | 8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b (patch) | |
tree | cd0de6a4642b76b42002dae5291c307d30727bc6 /common/commandline/zsh.nix | |
parent | 46ac3d5464712d6b0e0bee4ac62543abcbf2db2c (diff) | |
download | nixos-config-reborn-8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b.tar.gz nixos-config-reborn-8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b.zip |
revamp with nix flakes + desktop config
Diffstat (limited to 'common/commandline/zsh.nix')
-rw-r--r-- | common/commandline/zsh.nix | 21 |
1 files changed, 16 insertions, 5 deletions
diff --git a/common/commandline/zsh.nix b/common/commandline/zsh.nix index 3376321..28899b1 100644 --- a/common/commandline/zsh.nix +++ b/common/commandline/zsh.nix | |||
@@ -1,3 +1,5 @@ | |||
1 | inputs: | ||
2 | |||
1 | { config, lib, pkgs, ... }: | 3 | { config, lib, pkgs, ... }: |
2 | 4 | ||
3 | with import ../../lib/theme.nix { inherit lib; }; | 5 | with import ../../lib/theme.nix { inherit lib; }; |
@@ -13,9 +15,6 @@ in | |||
13 | source "${pkgs.grml-zsh-config}/etc/zsh/zshrc" | 15 | source "${pkgs.grml-zsh-config}/etc/zsh/zshrc" |
14 | is4 && xsource "${pkgs.grml-zsh-config}/etc/zsh/keephack" | 16 | is4 && xsource "${pkgs.grml-zsh-config}/etc/zsh/keephack" |
15 | 17 | ||
16 | PATH="${pkgs.pazi}/bin:$PATH" | ||
17 | eval "$(pazi init zsh)" | ||
18 | |||
19 | source "${pkgs.zsh-history-substring-search}/share/zsh-history-substring-search/zsh-history-substring-search.zsh" | 18 | source "${pkgs.zsh-history-substring-search}/share/zsh-history-substring-search/zsh-history-substring-search.zsh" |
20 | 19 | ||
21 | function () { | 20 | function () { |
@@ -30,8 +29,6 @@ in | |||
30 | (mapAttrsToList | 29 | (mapAttrsToList |
31 | (variable: value: "${variable}=\"${value}\"") | 30 | (variable: value: "${variable}=\"${value}\"") |
32 | config.programs.less.envVariables)} | 31 | config.programs.less.envVariables)} |
33 | |||
34 | #eval "$(${pkgs.starship}/bin/starship init zsh)" | ||
35 | ''; | 32 | ''; |
36 | 33 | ||
37 | # otherwise it'll override the grml prompt | 34 | # otherwise it'll override the grml prompt |
@@ -56,4 +53,18 @@ in | |||
56 | }; | 53 | }; |
57 | 54 | ||
58 | users.defaultUserShell = pkgs.zsh; | 55 | users.defaultUserShell = pkgs.zsh; |
56 | |||
57 | home-manager.users.minijackson = { ... }: { | ||
58 | # Allows zsh config from home-manager | ||
59 | programs.zsh = { | ||
60 | enable = true; | ||
61 | # Completion is already handled by the GRML conf | ||
62 | enableCompletion = false; | ||
63 | }; | ||
64 | }; | ||
65 | |||
66 | home-manager.users.root = { ... }: { | ||
67 | programs.zsh = | ||
68 | lib.mkDefault config.home-manager.users.minijackson.programs.zsh; | ||
69 | }; | ||
59 | } | 70 | } |