summaryrefslogtreecommitdiffstats
path: root/common/commandline/zsh.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2024-04-13 21:51:35 +0200
committerMinijackson <minijackson@riseup.net>2024-04-13 21:51:35 +0200
commit01b93181d7f45d284bfc6abcaffe2d3a51e9f409 (patch)
tree732843949a09d64a31cd05af888533bd07437142 /common/commandline/zsh.nix
parent40a76d6fce9d09b22fac350b391609cf220599e2 (diff)
downloadnixos-config-reborn-01b93181d7f45d284bfc6abcaffe2d3a51e9f409.tar.gz
nixos-config-reborn-01b93181d7f45d284bfc6abcaffe2d3a51e9f409.zip
common/zsh: better history options
Diffstat (limited to 'common/commandline/zsh.nix')
-rw-r--r--common/commandline/zsh.nix16
1 files changed, 12 insertions, 4 deletions
diff --git a/common/commandline/zsh.nix b/common/commandline/zsh.nix
index f11cb37..d1fdee7 100644
--- a/common/commandline/zsh.nix
+++ b/common/commandline/zsh.nix
@@ -66,11 +66,8 @@ in {
66 }; 66 };
67 67
68 setOptions = [ 68 setOptions = [
69 "HIST_IGNORE_DUPS"
70 "SHARE_HISTORY"
71 "HIST_FCNTL_LOCK"
72 "NO_CLOBBER"
73 "NO_CASE_GLOB" 69 "NO_CASE_GLOB"
70 "NO_CLOBBER"
74 ]; 71 ];
75 }; 72 };
76 73
@@ -83,6 +80,17 @@ in {
83 # Completion is already handled by the GRML conf 80 # Completion is already handled by the GRML conf
84 enableCompletion = false; 81 enableCompletion = false;
85 82
83 history = {
84 extended = true;
85 expireDuplicatesFirst = true;
86 ignoreDups = true;
87 ignorePatterns = ["run-help *"];
88
89 # different, for expireDuplicatesFirst
90 size = 1100;
91 save = 1000;
92 };
93
86 # XDG 94 # XDG
87 dotDir = ".config/zsh"; 95 dotDir = ".config/zsh";
88 history.path = "${config.xdg.dataHome}/zsh/zsh_history"; 96 history.path = "${config.xdg.dataHome}/zsh/zsh_history";