diff options
Diffstat (limited to 'mdbook.nix')
-rw-r--r-- | mdbook.nix | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -6,6 +6,8 @@ with lib; | |||
6 | 6 | ||
7 | let | 7 | let |
8 | cfg = getAttrFromPath (optionsAttrPath ++ [ "mdbook" ]) config; | 8 | cfg = getAttrFromPath (optionsAttrPath ++ [ "mdbook" ]) config; |
9 | |||
10 | documentation-highlighter = pkgs.callPackage ./documentation-highlighter { }; | ||
9 | in | 11 | in |
10 | { | 12 | { |
11 | options = setAttrByPath optionsAttrPath { | 13 | options = setAttrByPath optionsAttrPath { |
@@ -110,8 +112,8 @@ in | |||
110 | cd */ | 112 | cd */ |
111 | 113 | ||
112 | mkdir theme | 114 | mkdir theme |
113 | cp ${pkgs.documentation-highlighter}/highlight.pack.js theme/highlight.js | 115 | cp ${documentation-highlighter}/highlight.min.js theme/highlight.js |
114 | cp ${pkgs.documentation-highlighter}/mono-blue.css theme/highlight.css | 116 | cp ${documentation-highlighter}/mono-blue.min.css theme/highlight.css |
115 | 117 | ||
116 | ${concatMapStrings (page: '' | 118 | ${concatMapStrings (page: '' |
117 | cp "${page.source}" "src/${page.target}" | 119 | cp "${page.source}" "src/${page.target}" |