summaryrefslogtreecommitdiffstats
path: root/doc-options-md.nix
diff options
context:
space:
mode:
Diffstat (limited to 'doc-options-md.nix')
-rw-r--r--doc-options-md.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/doc-options-md.nix b/doc-options-md.nix
index ea21746..5cbc7c2 100644
--- a/doc-options-md.nix
+++ b/doc-options-md.nix
@@ -7,8 +7,12 @@ with lib;
7let 7let
8 visibleOptionDocs = filter (opt: opt.visible && !opt.internal) (optionAttrSetToDocList options); 8 visibleOptionDocs = filter (opt: opt.visible && !opt.internal) (optionAttrSetToDocList options);
9 9
10 isLiteral = value:
11 value ? _type &&
12 (value._type == "literalExpression" || value._type == "literalExample");
13
10 toValue = value: 14 toValue = value:
11 if value ? _type && value._type == "literalExpression" then value.text 15 if isLiteral value then value.text
12 else generators.toPretty { } value; 16 else generators.toPretty { } value;
13 17
14 toMarkdown = option: 18 toMarkdown = option: