summaryrefslogtreecommitdiffstats
path: root/examples/dummyresource/resourcefactory.h
Commit message (Collapse)AuthorAge
* Cleanup.Christian Mollekopf2018-08-02
|
* Adapt to KAsync changesChristian Mollekopf2017-03-01
|
* Used the CommandProcessor as central place for all command processing.Christian Mollekopf2016-11-28
|
* Moved inspection commands to a separate inspector.Christian Mollekopf2016-11-28
|
* Implement debug stream operators for query.Christian Mollekopf2016-11-07
|
* Specify the resource name in one placeChristian Mollekopf2016-10-21
|
* Refactor how the storage is used.Christian Mollekopf2016-10-21
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | This is the initial refactoring to improve how we deal with the storage. It does a couple of things: * Rename Sink::Storage to Sink::Storage::DataStore to free up the Sink::Storage namespace * Introduce a Sink::ResourceContext to have a single object that can be passed around containing everything that is necessary to operate on a resource. This is a lot better than the multiple separate parameters that we used to pass around all over the place, while still allowing for dependency injection for tests. * Tie storage access together using the new EntityStore that directly works with ApplicationDomainTypes. This gives us a central place where main storage, indexes and buffer adaptors are tied together, which will also give us a place to implement external indexes, such as a fulltextindex using xapian. * Use ApplicationDomainTypes as the default way to pass around entities. Instead of using various ways to pass around entities (buffers, buffer adaptors, ApplicationDomainTypes), only use a single way. The old approach was confusing, and was only done as: * optimization; really shouldn't be necessary and otherwise I'm sure we can find better ways to optimize ApplicationDomainType itself. * a way to account for entities that have multiple buffers, a concept that I no longer deem relevant. While this commit does the bulk of the work to get there, the following commits will refactor more stuff to get things back to normal.
* Avoid using the resource object to remove the data from disk.Christian Mollekopf2016-10-07
| | | | | ...because creating it will potentially start transactions on the database we're about to remove.
* Shorten the types to be more distinctive.Christian Mollekopf2016-07-08
| | | | | The org.kde prefix is useless and possibly misleading. Simply prefixing with sink is more unique and shorter.
* Test the resource statusChristian Mollekopf2016-07-06
|
* Dummyresource cleanupChristian Mollekopf2016-05-30
|
* Fixed genericresource so it works with the maildirresourcetestChristian Mollekopf2016-05-29
|
* Refactored the generic resource to use separate classes forChristian Mollekopf2016-05-28
| | | | | | | | changereplay and synchronization. This cleans up the API and avoids the excessive passing around of transactions. It also provides more flexibility in eventually using different synchronization strategies for different resources.
* Executed database removal in the resource instead of the client.Christian Mollekopf2016-02-08
| | | | | The resource doesn't really notify all clients properly about the removal, but the tests all still pass.
* Renamed Akonadi2 to SinkChristian Mollekopf2016-01-20
| | | | (except for documentation).
* Working resource inspectionChristian Mollekopf2016-01-18
|
* Draft of inspection APIChristian Mollekopf2016-01-18
|
* Use the existing synchronization facilities also in the DummyResourceChristian Mollekopf2015-12-30
|
* Centralize where we create the storesChristian Mollekopf2015-12-30
|
* Use the domain adaptor in the synchornization code of the dummyChristian Mollekopf2015-12-17
| | | | | | | resource as well. The code is easier to read that way, depends less on flatbuffers, and there is no measurable impact on performance.
* A change-replay functionChristian Mollekopf2015-12-10
|
* Added mail and folder propertiesChristian Mollekopf2015-12-04
|
* Synchronizer: One transaction per sync, and check if entity alreadyChristian Mollekopf2015-12-01
| | | | | | exists. With this we no longer repeatedly create entities on every sync.
* Resolve remoteIds during syncChristian Mollekopf2015-12-01
| | | | | | | Remote id's need to be resolved while syncing any references. This is done by the synchronizer by consulting the rid to entity id mapping. If the referenced entity doesn't exist yet we create a local id anyways, that we then need to pick up once the actual entity arrives.
* Loading data with the new model for the test clientChristian Mollekopf2015-11-19
|
* Added a removeFromDisk method to the resourceChristian Mollekopf2015-10-21
|
* Reduced duplication in dummy synchronization codeChristian Mollekopf2015-09-08
|
* DummyStore that is not overly complicated by using flatbuffers.Christian Mollekopf2015-09-08
|
* Added support for mails to akonadi and the dummyresource.Christian Mollekopf2015-09-08
| | | | Adding new types definitely needs to become easier.
* Made the pipeline an implementation detail of the resource.Christian Mollekopf2015-07-30
| | | | | This removes one dependency from the Listener and will allow us to test the Listener better.
* Use the resource instance nameChristian Mollekopf2015-07-07
|
* KAsync has moved to it's own kasync.git repositoryDan Vrátil2015-05-18
|
* Adapt to KAsync namespace changeDan Vrátil2015-05-15
|
* Moved generic part of resource implementation to GenericResourceChristian Mollekopf2015-04-20
|
* Moved client and dummyresource to examples/Christian Mollekopf2015-04-19