| Commit message (Collapse) | Author | Age |
|
|
|
| |
..because there is a boatload more to fix.
|
| |
|
| |
|
|
|
|
|
|
|
| |
To have hierarchical debug output we have to pass around something at
run-time, there is no reasonable alternative. Log::Context provides the
identifier to do just that and largely replaces the debug component
idea.
|
| |
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
This is the initial refactoring to improve how we deal with the storage.
It does a couple of things:
* Rename Sink::Storage to Sink::Storage::DataStore to free up the
Sink::Storage namespace
* Introduce a Sink::ResourceContext to have a single object that can be
passed around containing everything that is necessary to operate on a
resource. This is a lot better than the multiple separate parameters
that we used to pass around all over the place, while still allowing
for dependency injection for tests.
* Tie storage access together using the new EntityStore that directly
works with ApplicationDomainTypes. This gives us a central place where
main storage, indexes and buffer adaptors are tied together, which
will also give us a place to implement external indexes, such as a
fulltextindex using xapian.
* Use ApplicationDomainTypes as the default way to pass around entities.
Instead of using various ways to pass around entities (buffers,
buffer adaptors, ApplicationDomainTypes), only use a single way.
The old approach was confusing, and was only done as:
* optimization; really shouldn't be necessary and otherwise I'm sure
we can find better ways to optimize ApplicationDomainType itself.
* a way to account for entities that have multiple buffers, a concept
that I no longer deem relevant.
While this commit does the bulk of the work to get there, the following
commits will refactor more stuff to get things back to normal.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Instead of a single #define as debug area the new system allows for an
identifier for each debug message with the structure component.area.
The component is a dot separated identifier of the runtime component,
such as the process or the plugin.
The area is the code component, and can be as such defined at
compiletime.
The idea of this system is that it becomes possible to i.e. look at the
output of all messages in the query subsystem of a specific resource
(something that happens in the client process, but in the
resource-specific subcomponent).
The new macros are supposed to be less likely to clash with other names,
hence the new names.
|
| |
|
|
|
|
| |
clang-format -i */**{.cpp,.h}
|
| |
|
| |
|
|
|
|
|
|
| |
This can be used to modify each result before reporting it to the
client. Alternatively this could also be done in the DomainTypeAdaptor,
which would perhaps be the cleaner solution...
|
| |
|
|
|
|
|
|
|
|
|
| |
This cuts the exportet symbols from 12k to 2k and the library size from
16Mb to 14Mb, which isn't great but still an improvement.
About 30% of the symbols are coming from the Store:: interface.
nm -C -D /work/install/lib64/libsinkcommon.so.0.1
|
|
|
|
| |
(except for documentation).
|
|
|
|
|
|
|
|
| |
The QueryRunner object lives for the duration of the query (so just
for the initial query for non-live queries, and for the lifetime of the
result model for live queries).
It's supposed to handle all the threading internally and decouple the
lifetime of the facade.
|
|
|
|
|
| |
Although, the benchmarks say it doesn't really have an impact on
performance.
|
|
|
|
| |
Without this modifications are ignored also in incremental queries.
|
| |
|
| |
|
| |
|
| |
|
| |
|
|
|
|
| |
We're not doing any lifetime management anyways.
|
| |
|
| |
|
|
|
|
| |
sync has been removed from the query code and is now a separate step
|
| |
|
| |
|
| |
|
| |
|
| |
|
|
|
|
|
| |
To avoid unnecessary abstraction layers that don't solve a problem,
and to allow facades to customize how entities are loaded.
|
|
|
|
|
| |
Now we just have to avoid removing the revision too early from the
resource.
|
|
|
|
| |
We can just as well read the latest available revision from storage.
|
|
|
|
|
| |
So far only includes modifications and additions,
removals are not yet stored as separate revisions.
|
|
|
|
| |
Adding new types definitely needs to become easier.
|
|
|
|
| |
We no longer depend on clientapi.h from everywhere.
|
|
|
|
| |
So we have commands in one place, and not in a header file.
|
| |
|
| |
|
|
|
|
| |
place
|
|
|
|
|
| |
Instead of clearing the result everytime we only query for the stuff
that has changed.
|
| |
|
| |
|
| |
|
| |
|
| |
|
|
|
|
| |
A default implementation is now nothing but an empty shell.
|