summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..1629acb
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,17 @@
1set(CMAKE_AUTOMOC ON)
2include_directories(${CMAKE_CURRENT_BINARY_DIR})
3
4generate_flatbuffers(calendar)
5
6macro(manual_tests)
7 foreach(_testname ${ARGN})
8 add_executable(${_testname} ${_testname}.cpp)
9 qt5_use_modules(${_testname} Core Test Concurrent)
10 target_link_libraries(${_testname} akonadinextcommon)
11 endforeach(_testname)
12endmacro(manual_tests)
13
14manual_tests (
15 storagebenchmark
16 storagetest
17)