summaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt19
1 files changed, 11 insertions, 8 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index 001dab5..ec13e07 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -1,13 +1,16 @@
1project(akonadi2common) 1project(akonadi2common)
2generate_flatbuffers( 2generate_flatbuffers(
3 commands/commandcompletion 3 commands/commandcompletion
4 commands/createentity 4 commands/createentity
5 commands/deleteentity 5 commands/deleteentity
6 commands/fetchentity 6 commands/fetchentity
7 commands/handshake 7 commands/handshake
8 commands/modifyentity 8 commands/modifyentity
9 commands/revisionupdate 9 commands/revisionupdate
10 ) 10 domain/event
11 entitybuffer
12 metadata
13)
11 14
12if (STORAGE_unqlite) 15if (STORAGE_unqlite)
13 add_definitions(-DUNQLITE_ENABLE_THREADS -fpermissive) 16 add_definitions(-DUNQLITE_ENABLE_THREADS -fpermissive)