diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 8213bed..c80f313 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -23,6 +23,9 @@ find_package(Qt5 COMPONENTS REQUIRED Core Widgets Network) | |||
23 | find_package(KF5 COMPONENTS REQUIRED Async Mime) | 23 | find_package(KF5 COMPONENTS REQUIRED Async Mime) |
24 | find_package(FlatBuffers REQUIRED) | 24 | find_package(FlatBuffers REQUIRED) |
25 | 25 | ||
26 | find_program(MEMORYCHECK_COMMAND valgrind) | ||
27 | set(MEMORYCHECK_COMMAND_OPTIONS "--trace-children=yes --leak-check=full") | ||
28 | |||
26 | #Clang-format support | 29 | #Clang-format support |
27 | add_custom_command( | 30 | add_custom_command( |
28 | OUTPUT format.dummy | 31 | OUTPUT format.dummy |
@@ -75,7 +78,7 @@ if (${CATCH_ERRORS}) | |||
75 | add_definitions("-Werror -Wall -Weverything -Wno-unused-function -Wno-cast-align -Wno-used-but-marked-unused -Wno-shadow -Wno-weak-vtables -Wno-global-constructors -Wno-deprecated -Wno-weak-template-vtables -Wno-exit-time-destructors -Wno-covered-switch-default -Wno-shorten-64-to-32 -Wno-documentation -Wno-old-style-cast -Wno-extra-semi -Wno-unused-parameter -Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-padded -Wno-missing-noreturn -Wno-missing-prototypes -Wno-documentation-unknown-command -Wno-sign-conversion -Wno-gnu-zero-variadic-macro-arguments -Wno-disabled-macro-expansion -Wno-vla-extension -Wno-vla") | 78 | add_definitions("-Werror -Wall -Weverything -Wno-unused-function -Wno-cast-align -Wno-used-but-marked-unused -Wno-shadow -Wno-weak-vtables -Wno-global-constructors -Wno-deprecated -Wno-weak-template-vtables -Wno-exit-time-destructors -Wno-covered-switch-default -Wno-shorten-64-to-32 -Wno-documentation -Wno-old-style-cast -Wno-extra-semi -Wno-unused-parameter -Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-padded -Wno-missing-noreturn -Wno-missing-prototypes -Wno-documentation-unknown-command -Wno-sign-conversion -Wno-gnu-zero-variadic-macro-arguments -Wno-disabled-macro-expansion -Wno-vla-extension -Wno-vla") |
76 | endif() | 79 | endif() |
77 | add_definitions("-std=c++0x -g") | 80 | add_definitions("-std=c++0x -g") |
78 | include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${FLATBUFFERS_INCLUDE_DIR} ${CMAKE_BINARY_DIR}/common) | 81 | include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${FLATBUFFERS_INCLUDE_DIR} ${CMAKE_BINARY_DIR}/common 3rdparty) |
79 | include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/common/domain) | 82 | include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/common/domain) |
80 | 83 | ||
81 | configure_file(hawd.conf hawd.conf) | 84 | configure_file(hawd.conf hawd.conf) |