diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 7 |
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index dcc5224..45a6ef5 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,4 +1,4 @@ | |||
1 | cmake_minimum_required(VERSION 2.8) | 1 | cmake_minimum_required(VERSION 2.8.12) |
2 | 2 | ||
3 | 3 | ||
4 | # ECM setup | 4 | # ECM setup |
@@ -19,7 +19,7 @@ include(KDEInstallDirs) | |||
19 | # include(KDECMakeSettings) | 19 | # include(KDECMakeSettings) |
20 | 20 | ||
21 | find_package(Qt5 COMPONENTS REQUIRED Core Widgets Network) | 21 | find_package(Qt5 COMPONENTS REQUIRED Core Widgets Network) |
22 | 22 | find_package(KF5 COMPONENTS REQUIRED Async) | |
23 | find_package(FlatBuffers REQUIRED) | 23 | find_package(FlatBuffers REQUIRED) |
24 | function(generate_flatbuffers _target) | 24 | function(generate_flatbuffers _target) |
25 | foreach(fbs ${ARGN}) | 25 | foreach(fbs ${ARGN}) |
@@ -59,7 +59,4 @@ add_subdirectory(examples) | |||
59 | # some tests | 59 | # some tests |
60 | add_subdirectory(tests) | 60 | add_subdirectory(tests) |
61 | 61 | ||
62 | # async library prototype | ||
63 | add_subdirectory(async) | ||
64 | |||
65 | feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES) | 62 | feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES) |