diff options
author | Aaron Seigo <aseigo@kde.org> | 2014-12-05 10:05:19 +0100 |
---|---|---|
committer | Aaron Seigo <aseigo@kde.org> | 2014-12-05 10:05:19 +0100 |
commit | 93d1c82ffd17df45a5cecd875a01ee3cb15d9983 (patch) | |
tree | cda5c31857362ce81f3a50959024f4270d149a07 /tests/CMakeLists.txt | |
parent | 639fc60c100204c87b93112516cf3b3117cfff0d (diff) | |
parent | 351a66b5fb1c8659bff8ea20d60f5a6d2d3263ad (diff) | |
download | sink-93d1c82ffd17df45a5cecd875a01ee3cb15d9983.tar.gz sink-93d1c82ffd17df45a5cecd875a01ee3cb15d9983.zip |
Merge branch 'kyoto'
Conflicts:
common/storage.h
common/storage_lmdb.cpp
dummyresource/facade.cpp
store/test/CMakeLists.txt
tests/storagebenchmark.cpp
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r-- | tests/CMakeLists.txt | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt new file mode 100644 index 0000000..1629acb --- /dev/null +++ b/tests/CMakeLists.txt | |||
@@ -0,0 +1,17 @@ | |||
1 | set(CMAKE_AUTOMOC ON) | ||
2 | include_directories(${CMAKE_CURRENT_BINARY_DIR}) | ||
3 | |||
4 | generate_flatbuffers(calendar) | ||
5 | |||
6 | macro(manual_tests) | ||
7 | foreach(_testname ${ARGN}) | ||
8 | add_executable(${_testname} ${_testname}.cpp) | ||
9 | qt5_use_modules(${_testname} Core Test Concurrent) | ||
10 | target_link_libraries(${_testname} akonadinextcommon) | ||
11 | endforeach(_testname) | ||
12 | endmacro(manual_tests) | ||
13 | |||
14 | manual_tests ( | ||
15 | storagebenchmark | ||
16 | storagetest | ||
17 | ) | ||