diff options
author | Heiko Becker <heirecka@exherbo.org> | 2017-05-13 00:11:45 +0200 |
---|---|---|
committer | Heiko Becker <heirecka@exherbo.org> | 2017-07-29 11:00:15 +0200 |
commit | 9e6952baf64b51fa7ddb6ac91d4ce79ebfd2b2df (patch) | |
tree | 3a38a173968d2902cbc2459a17126ccb4e4c8cfb /tests/CMakeLists.txt | |
parent | 5275b0f173579162176e2340cbb9eaedafe8334a (diff) | |
download | sink-9e6952baf64b51fa7ddb6ac91d4ce79ebfd2b2df.tar.gz sink-9e6952baf64b51fa7ddb6ac91d4ce79ebfd2b2df.zip |
Use imported targets instead of qt5_use_modules
From Qt's documentation: "This macro is obsolete. Use
target_link_libraries with IMPORTED targets instead." It's only
recommended with cmake >=2.8.9 & < 2.8.12. Sink already requires
cmake 3.0. One advantage of using the imported targets is, that
cmake complains if a target isn't found before it's used, like
Qt5Concurrent missing from the find_package_call here.
Reviewers: #sink, cmollekopf
Reviewed By: #sink, cmollekopf
Subscribers: #sink
Tags: #sink
Differential Revision: https://phabricator.kde.org/D6361
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r-- | tests/CMakeLists.txt | 10 |
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt index 2b3e7b1..b0333a4 100644 --- a/tests/CMakeLists.txt +++ b/tests/CMakeLists.txt | |||
@@ -13,8 +13,14 @@ add_definitions(-DTESTDATAPATH="${CMAKE_CURRENT_SOURCE_DIR}/data") | |||
13 | find_package(KF5 COMPONENTS REQUIRED Mime) | 13 | find_package(KF5 COMPONENTS REQUIRED Mime) |
14 | 14 | ||
15 | add_library(sink_test SHARED testimplementations.cpp getrssusage.cpp mailtest.cpp mailsynctest.cpp mailthreadtest.cpp) | 15 | add_library(sink_test SHARED testimplementations.cpp getrssusage.cpp mailtest.cpp mailsynctest.cpp mailthreadtest.cpp) |
16 | qt5_use_modules(sink_test Core Test Concurrent) | 16 | target_link_libraries(sink_test |
17 | target_link_libraries(sink_test sink libhawd KF5::Mime) | 17 | sink |
18 | libhawd | ||
19 | Qt5::Core | ||
20 | Qt5::Concurrent | ||
21 | Qt5::Test | ||
22 | KF5::Mime | ||
23 | ) | ||
18 | 24 | ||
19 | add_executable(dbwriter dbwriter.cpp) | 25 | add_executable(dbwriter dbwriter.cpp) |
20 | target_link_libraries(dbwriter sink) | 26 | target_link_libraries(dbwriter sink) |