diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2018-05-28 14:27:42 +0200 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2018-05-28 14:27:42 +0200 |
commit | f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a (patch) | |
tree | 8672ddcc98760c03c5bd91daac1fdd931c7bff41 /examples/imapresource/CMakeLists.txt | |
parent | 90900beea1092ca3cd194ee88b0c2e26244c2ba6 (diff) | |
download | sink-f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a.tar.gz sink-f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a.zip |
Avoid building tests that link to the resource on windows.
Because we'd have to properly export the symbols for the linking on
windows to work.
Diffstat (limited to 'examples/imapresource/CMakeLists.txt')
-rw-r--r-- | examples/imapresource/CMakeLists.txt | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/imapresource/CMakeLists.txt b/examples/imapresource/CMakeLists.txt index 61b86ed..478ce2f 100644 --- a/examples/imapresource/CMakeLists.txt +++ b/examples/imapresource/CMakeLists.txt | |||
@@ -12,4 +12,8 @@ target_link_libraries(${PROJECT_NAME} sink Qt5::Core Qt5::Network KF5::Mime KIMA | |||
12 | 12 | ||
13 | install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${SINK_RESOURCE_PLUGINS_PATH} RUNTIME DESTINATION ${SINK_RESOURCE_PLUGINS_PATH}) | 13 | install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${SINK_RESOURCE_PLUGINS_PATH} RUNTIME DESTINATION ${SINK_RESOURCE_PLUGINS_PATH}) |
14 | 14 | ||
15 | add_subdirectory(tests) | 15 | if (WIN32) |
16 | message("Not building imap resource tests on windows") | ||
17 | else() | ||
18 | add_subdirectory(tests) | ||
19 | endif() | ||