summaryrefslogtreecommitdiffstats
path: root/examples/imapresource/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2018-05-28 14:27:42 +0200
committerChristian Mollekopf <chrigi_1@fastmail.fm>2018-05-28 14:27:42 +0200
commitf4b9bb3e15a9a8201bfaf47a07b2cca439080a5a (patch)
tree8672ddcc98760c03c5bd91daac1fdd931c7bff41 /examples/imapresource/CMakeLists.txt
parent90900beea1092ca3cd194ee88b0c2e26244c2ba6 (diff)
downloadsink-f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a.tar.gz
sink-f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a.zip
Avoid building tests that link to the resource on windows.
Because we'd have to properly export the symbols for the linking on windows to work.
Diffstat (limited to 'examples/imapresource/CMakeLists.txt')
-rw-r--r--examples/imapresource/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/imapresource/CMakeLists.txt b/examples/imapresource/CMakeLists.txt
index 61b86ed..478ce2f 100644
--- a/examples/imapresource/CMakeLists.txt
+++ b/examples/imapresource/CMakeLists.txt
@@ -12,4 +12,8 @@ target_link_libraries(${PROJECT_NAME} sink Qt5::Core Qt5::Network KF5::Mime KIMA
12 12
13install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${SINK_RESOURCE_PLUGINS_PATH} RUNTIME DESTINATION ${SINK_RESOURCE_PLUGINS_PATH}) 13install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${SINK_RESOURCE_PLUGINS_PATH} RUNTIME DESTINATION ${SINK_RESOURCE_PLUGINS_PATH})
14 14
15add_subdirectory(tests) 15if (WIN32)
16 message("Not building imap resource tests on windows")
17else()
18 add_subdirectory(tests)
19endif()