summaryrefslogtreecommitdiffstats
path: root/examples/carddavresource/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2018-05-28 14:27:42 +0200
committerChristian Mollekopf <chrigi_1@fastmail.fm>2018-05-28 14:27:42 +0200
commitf4b9bb3e15a9a8201bfaf47a07b2cca439080a5a (patch)
tree8672ddcc98760c03c5bd91daac1fdd931c7bff41 /examples/carddavresource/CMakeLists.txt
parent90900beea1092ca3cd194ee88b0c2e26244c2ba6 (diff)
downloadsink-f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a.tar.gz
sink-f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a.zip
Avoid building tests that link to the resource on windows.
Because we'd have to properly export the symbols for the linking on windows to work.
Diffstat (limited to 'examples/carddavresource/CMakeLists.txt')
-rw-r--r--examples/carddavresource/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/carddavresource/CMakeLists.txt b/examples/carddavresource/CMakeLists.txt
index 0db0e1a..0632804 100644
--- a/examples/carddavresource/CMakeLists.txt
+++ b/examples/carddavresource/CMakeLists.txt
@@ -9,4 +9,8 @@ target_link_libraries(${PROJECT_NAME} sink_webdav_common sink Qt5::Core Qt5::Net
9 9
10install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${SINK_RESOURCE_PLUGINS_PATH} RUNTIME DESTINATION ${SINK_RESOURCE_PLUGINS_PATH}) 10install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${SINK_RESOURCE_PLUGINS_PATH} RUNTIME DESTINATION ${SINK_RESOURCE_PLUGINS_PATH})
11 11
12add_subdirectory(tests) 12if (WIN32)
13 message("Not building carddav resource tests on windows")
14else()
15 add_subdirectory(tests)
16endif()