summaryrefslogtreecommitdiffstats
path: root/examples/caldavresource/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2018-05-28 14:27:42 +0200
committerChristian Mollekopf <chrigi_1@fastmail.fm>2018-05-28 14:27:42 +0200
commitf4b9bb3e15a9a8201bfaf47a07b2cca439080a5a (patch)
tree8672ddcc98760c03c5bd91daac1fdd931c7bff41 /examples/caldavresource/CMakeLists.txt
parent90900beea1092ca3cd194ee88b0c2e26244c2ba6 (diff)
downloadsink-f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a.tar.gz
sink-f4b9bb3e15a9a8201bfaf47a07b2cca439080a5a.zip
Avoid building tests that link to the resource on windows.
Because we'd have to properly export the symbols for the linking on windows to work.
Diffstat (limited to 'examples/caldavresource/CMakeLists.txt')
-rw-r--r--examples/caldavresource/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/caldavresource/CMakeLists.txt b/examples/caldavresource/CMakeLists.txt
index 353f0d7..d2859aa 100644
--- a/examples/caldavresource/CMakeLists.txt
+++ b/examples/caldavresource/CMakeLists.txt
@@ -11,4 +11,8 @@ target_link_libraries(${PROJECT_NAME} sink_webdav_common sink Qt5::Core Qt5::Net
11 11
12install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${SINK_RESOURCE_PLUGINS_PATH} RUNTIME DESTINATION ${SINK_RESOURCE_PLUGINS_PATH}) 12install(TARGETS ${PROJECT_NAME} LIBRARY DESTINATION ${SINK_RESOURCE_PLUGINS_PATH} RUNTIME DESTINATION ${SINK_RESOURCE_PLUGINS_PATH})
13 13
14add_subdirectory(tests) 14if (WIN32)
15 message("Not building caldavresource resource tests on windows")
16else()
17 add_subdirectory(tests)
18endif()