diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2018-05-29 10:25:29 +0200 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2018-05-29 10:25:29 +0200 |
commit | 4d33a89d3e1a04b2be9f7c51f53062af0a7377c1 (patch) | |
tree | c510056205e36ac65dcccf9f217ee5331715da5a /common/CMakeLists.txt | |
parent | 1c499e40b3f0e676e2e954bf1d7c46873538d461 (diff) | |
download | sink-4d33a89d3e1a04b2be9f7c51f53062af0a7377c1.tar.gz sink-4d33a89d3e1a04b2be9f7c51f53062af0a7377c1.zip |
Cleanup
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r-- | common/CMakeLists.txt | 7 |
1 files changed, 2 insertions, 5 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt index c8e178a..970990f 100644 --- a/common/CMakeLists.txt +++ b/common/CMakeLists.txt | |||
@@ -28,9 +28,7 @@ set(CMAKE_CXX_VISIBILITY_PRESET default) | |||
28 | 28 | ||
29 | install(EXPORT SinkTargets DESTINATION "${CMAKECONFIG_INSTALL_DIR}" FILE SinkTargets.cmake) | 29 | install(EXPORT SinkTargets DESTINATION "${CMAKECONFIG_INSTALL_DIR}" FILE SinkTargets.cmake) |
30 | 30 | ||
31 | set(storage_SRCS storage_lmdb.cpp) | 31 | add_library(${PROJECT_NAME} SHARED |
32 | |||
33 | set(command_SRCS | ||
34 | store.cpp | 32 | store.cpp |
35 | secretstore.cpp | 33 | secretstore.cpp |
36 | notifier.cpp | 34 | notifier.cpp |
@@ -84,9 +82,8 @@ set(command_SRCS | |||
84 | propertyparser.cpp | 82 | propertyparser.cpp |
85 | utils.cpp | 83 | utils.cpp |
86 | fulltextindex.cpp | 84 | fulltextindex.cpp |
87 | ${storage_SRCS}) | 85 | storage_lmdb.cpp) |
88 | 86 | ||
89 | add_library(${PROJECT_NAME} SHARED ${command_SRCS}) | ||
90 | 87 | ||
91 | generate_flatbuffers( | 88 | generate_flatbuffers( |
92 | ${PROJECT_NAME} | 89 | ${PROJECT_NAME} |