summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-07-11 14:08:19 +0200
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-07-11 14:08:19 +0200
commita0c09c8f46ae665ec9c03178742f8e2f32f92af2 (patch)
tree45e414dc30aa2fba648bc1f35f24befe1e11603e /CMakeLists.txt
parent3a3118e768e1447dc7524328e84b8d7faef81fe1 (diff)
downloadsink-a0c09c8f46ae665ec9c03178742f8e2f32f92af2.tar.gz
sink-a0c09c8f46ae665ec9c03178742f8e2f32f92af2.zip
Support valgrind directly in the buildsystem
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8213bed..c80f313 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,9 @@ find_package(Qt5 COMPONENTS REQUIRED Core Widgets Network)
23find_package(KF5 COMPONENTS REQUIRED Async Mime) 23find_package(KF5 COMPONENTS REQUIRED Async Mime)
24find_package(FlatBuffers REQUIRED) 24find_package(FlatBuffers REQUIRED)
25 25
26find_program(MEMORYCHECK_COMMAND valgrind)
27set(MEMORYCHECK_COMMAND_OPTIONS "--trace-children=yes --leak-check=full")
28
26#Clang-format support 29#Clang-format support
27add_custom_command( 30add_custom_command(
28 OUTPUT format.dummy 31 OUTPUT format.dummy
@@ -75,7 +78,7 @@ if (${CATCH_ERRORS})
75 add_definitions("-Werror -Wall -Weverything -Wno-unused-function -Wno-cast-align -Wno-used-but-marked-unused -Wno-shadow -Wno-weak-vtables -Wno-global-constructors -Wno-deprecated -Wno-weak-template-vtables -Wno-exit-time-destructors -Wno-covered-switch-default -Wno-shorten-64-to-32 -Wno-documentation -Wno-old-style-cast -Wno-extra-semi -Wno-unused-parameter -Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-padded -Wno-missing-noreturn -Wno-missing-prototypes -Wno-documentation-unknown-command -Wno-sign-conversion -Wno-gnu-zero-variadic-macro-arguments -Wno-disabled-macro-expansion -Wno-vla-extension -Wno-vla") 78 add_definitions("-Werror -Wall -Weverything -Wno-unused-function -Wno-cast-align -Wno-used-but-marked-unused -Wno-shadow -Wno-weak-vtables -Wno-global-constructors -Wno-deprecated -Wno-weak-template-vtables -Wno-exit-time-destructors -Wno-covered-switch-default -Wno-shorten-64-to-32 -Wno-documentation -Wno-old-style-cast -Wno-extra-semi -Wno-unused-parameter -Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-padded -Wno-missing-noreturn -Wno-missing-prototypes -Wno-documentation-unknown-command -Wno-sign-conversion -Wno-gnu-zero-variadic-macro-arguments -Wno-disabled-macro-expansion -Wno-vla-extension -Wno-vla")
76endif() 79endif()
77add_definitions("-std=c++0x -g") 80add_definitions("-std=c++0x -g")
78include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${FLATBUFFERS_INCLUDE_DIR} ${CMAKE_BINARY_DIR}/common) 81include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${FLATBUFFERS_INCLUDE_DIR} ${CMAKE_BINARY_DIR}/common 3rdparty)
79include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/common/domain) 82include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/common/domain)
80 83
81configure_file(hawd.conf hawd.conf) 84configure_file(hawd.conf hawd.conf)