diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-06-21 22:19:15 +0200 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-06-21 22:19:15 +0200 |
commit | 751f2c82c4121d28d0740bffb29a4fb273ec55c5 (patch) | |
tree | 05103eb2e09b905495969761eecf566be0d1f376 /CMakeLists.txt | |
parent | a1c6a7844cf8c9111b841ba0819a6856321d3397 (diff) | |
download | sink-751f2c82c4121d28d0740bffb29a4fb273ec55c5.tar.gz sink-751f2c82c4121d28d0740bffb29a4fb273ec55c5.zip |
Catch errors
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 1eb16a1..8213bed 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -72,7 +72,7 @@ endfunction() | |||
72 | 72 | ||
73 | set(CMAKE_AUTOMOC ON) | 73 | set(CMAKE_AUTOMOC ON) |
74 | if (${CATCH_ERRORS}) | 74 | if (${CATCH_ERRORS}) |
75 | add_definitions("-Werror -Wall -Weverything -Wno-unused-function -Wno-cast-align -Wno-used-but-marked-unused -Wno-shadow -Wno-weak-vtables -Wno-global-constructors -Wno-deprecated -Wno-weak-template-vtables -Wno-exit-time-destructors -Wno-covered-switch-default -Wno-shorten-64-to-32 -Wno-documentation -Wno-old-style-cast -Wno-extra-semi -Wno-unused-parameter -Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-padded -Wno-missing-noreturn -Wno-missing-prototypes -Wno-documentation-unknown-command -Wno-sign-conversion") | 75 | add_definitions("-Werror -Wall -Weverything -Wno-unused-function -Wno-cast-align -Wno-used-but-marked-unused -Wno-shadow -Wno-weak-vtables -Wno-global-constructors -Wno-deprecated -Wno-weak-template-vtables -Wno-exit-time-destructors -Wno-covered-switch-default -Wno-shorten-64-to-32 -Wno-documentation -Wno-old-style-cast -Wno-extra-semi -Wno-unused-parameter -Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-padded -Wno-missing-noreturn -Wno-missing-prototypes -Wno-documentation-unknown-command -Wno-sign-conversion -Wno-gnu-zero-variadic-macro-arguments -Wno-disabled-macro-expansion -Wno-vla-extension -Wno-vla") |
76 | endif() | 76 | endif() |
77 | add_definitions("-std=c++0x -g") | 77 | add_definitions("-std=c++0x -g") |
78 | include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${FLATBUFFERS_INCLUDE_DIR} ${CMAKE_BINARY_DIR}/common) | 78 | include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${FLATBUFFERS_INCLUDE_DIR} ${CMAKE_BINARY_DIR}/common) |