summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-10-13 18:38:35 +0200
committerChristian Mollekopf <chrigi_1@fastmail.fm>2018-02-11 23:03:17 +0100
commit6051c1247cde61bcc8e483eb4166e5a297c0ecc6 (patch)
treedf3aba1ef4011f2640b17c8cf7a9b106933231ab /CMakeLists.txt
parent8740a007515dcf1b315d69ab5c64fcfd40ec980c (diff)
downloadsink-6051c1247cde61bcc8e483eb4166e5a297c0ecc6.tar.gz
sink-6051c1247cde61bcc8e483eb4166e5a297c0ecc6.zip
Xapian based fulltext indexing
This cuts into the sync performance by about 40%, but gives us fast fulltext searching for all local content.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb6df73..3327afd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,7 @@ find_package(KF5 COMPONENTS REQUIRED Mime Contacts)
36find_package(FlatBuffers REQUIRED 1.4.0) 36find_package(FlatBuffers REQUIRED 1.4.0)
37find_package(KAsync REQUIRED 0.1.2) 37find_package(KAsync REQUIRED 0.1.2)
38find_package(LMDB REQUIRED 0.9) 38find_package(LMDB REQUIRED 0.9)
39find_package(Xapian REQUIRED 1.4)
39 40
40if (${ENABLE_MEMCHECK}) 41if (${ENABLE_MEMCHECK})
41 message("Enabled memcheck") 42 message("Enabled memcheck")