summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFilipe Saraiva <filipe@kde.org>2017-03-03 14:49:28 -0300
committerFilipe Saraiva <filipe@kde.org>2017-03-03 14:49:28 -0300
commit020b96e731de12cfeb166f1c457545dd3f8fde23 (patch)
treefd133105860220a1612c4964fb5300954e792a04 /CMakeLists.txt
parentbe652c12dfa5162d952f5226de453e1a29957c3a (diff)
downloadsink-020b96e731de12cfeb166f1c457545dd3f8fde23.tar.gz
sink-020b96e731de12cfeb166f1c457545dd3f8fde23.zip
Create and add FindLMDB to CMakeLists.txt
Currently CMakeLists doesn't look for LMDB, a required dependency for sink. This commit creates a FindLMDB script based in an original script available in BSD license and add it to CMakeLists.txt.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 84f4df6..532ad41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,7 @@ find_package(Qt5 COMPONENTS REQUIRED Core Network Gui)
29find_package(KF5 COMPONENTS REQUIRED Mime Contacts) 29find_package(KF5 COMPONENTS REQUIRED Mime Contacts)
30find_package(FlatBuffers REQUIRED) 30find_package(FlatBuffers REQUIRED)
31find_package(KAsync REQUIRED 0.1.0) 31find_package(KAsync REQUIRED 0.1.0)
32find_package(LMDB REQUIRED)
32 33
33find_program(MEMORYCHECK_COMMAND valgrind) 34find_program(MEMORYCHECK_COMMAND valgrind)
34set(MEMORYCHECK_COMMAND_OPTIONS "--trace-children=yes --leak-check=full") 35set(MEMORYCHECK_COMMAND_OPTIONS "--trace-children=yes --leak-check=full")