diff options
author | Heiko Becker <heirecka@exherbo.org> | 2017-05-13 00:11:45 +0200 |
---|---|---|
committer | Heiko Becker <heirecka@exherbo.org> | 2017-07-29 11:00:15 +0200 |
commit | 9e6952baf64b51fa7ddb6ac91d4ce79ebfd2b2df (patch) | |
tree | 3a38a173968d2902cbc2459a17126ccb4e4c8cfb /CMakeLists.txt | |
parent | 5275b0f173579162176e2340cbb9eaedafe8334a (diff) | |
download | sink-9e6952baf64b51fa7ddb6ac91d4ce79ebfd2b2df.tar.gz sink-9e6952baf64b51fa7ddb6ac91d4ce79ebfd2b2df.zip |
Use imported targets instead of qt5_use_modules
From Qt's documentation: "This macro is obsolete. Use
target_link_libraries with IMPORTED targets instead." It's only
recommended with cmake >=2.8.9 & < 2.8.12. Sink already requires
cmake 3.0. One advantage of using the imported targets is, that
cmake complains if a target isn't found before it's used, like
Qt5Concurrent missing from the find_package_call here.
Reviewers: #sink, cmollekopf
Reviewed By: #sink, cmollekopf
Subscribers: #sink
Tags: #sink
Differential Revision: https://phabricator.kde.org/D6361
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 36bd0e0..1d8aea2 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -25,7 +25,7 @@ include(CMakePackageConfigHelpers) | |||
25 | include(ECMSetupVersion) | 25 | include(ECMSetupVersion) |
26 | include(KDEInstallDirs) | 26 | include(KDEInstallDirs) |
27 | 27 | ||
28 | find_package(Qt5 COMPONENTS REQUIRED Core Network Gui) | 28 | find_package(Qt5 COMPONENTS REQUIRED Core Concurrent Network Gui Test) |
29 | find_package(KF5 COMPONENTS REQUIRED Mime Contacts) | 29 | find_package(KF5 COMPONENTS REQUIRED Mime Contacts) |
30 | find_package(FlatBuffers REQUIRED 1.4.0) | 30 | find_package(FlatBuffers REQUIRED 1.4.0) |
31 | find_package(KAsync REQUIRED 0.1.2) | 31 | find_package(KAsync REQUIRED 0.1.2) |