summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-01-31 11:21:48 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-01-31 11:21:48 +0100
commitcf8c6dfe32580d2d93cb67f496f50fa14c572f5c (patch)
treef06e531c8316810f6fed688f3d7c16fa6582c4ac /CMakeLists.txt
parent7c52358e3fc9798715895a57e6eee3274a2b84f3 (diff)
downloadsink-cf8c6dfe32580d2d93cb67f496f50fa14c572f5c.tar.gz
sink-cf8c6dfe32580d2d93cb67f496f50fa14c572f5c.zip
Enabled and fixed a bunch of warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f96f631..26f2f08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,8 @@ function(add_clang_static_analysis target)
58endfunction() 58endfunction()
59 59
60set(CMAKE_AUTOMOC ON) 60set(CMAKE_AUTOMOC ON)
61add_definitions("-Wall -std=c++0x -g") 61add_definitions("-Wall -Weverything -Wno-cast-align -Wno-used-but-marked-unused -Wno-shadow -Wno-weak-vtables -Wno-global-constructors -Wno-deprecated -Wno-weak-template-vtables -Wno-exit-time-destructors -Wno-covered-switch-default -Wno-shorten-64-to-32 -Wno-documentation -Wno-old-style-cast -Wno-extra-semi -Wno-unused-parameter -Wno-c++98-compat -Wno-c++98-compat-pedantic -Wno-padded -Wno-missing-noreturn -Wno-missing-prototypes -Wno-documentation-unknown-command -Wno-sign-conversion")
62add_definitions("-std=c++0x -g")
62include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${FLATBUFFERS_INCLUDE_DIR} ${CMAKE_BINARY_DIR}/common) 63include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${FLATBUFFERS_INCLUDE_DIR} ${CMAKE_BINARY_DIR}/common)
63include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/common/domain) 64include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/common ${CMAKE_SOURCE_DIR}/common/domain)
64 65