diff options
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r-- | tests/CMakeLists.txt | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt index 35b28559..d7dfe81d 100644 --- a/tests/CMakeLists.txt +++ b/tests/CMakeLists.txt | |||
@@ -1,6 +1,7 @@ | |||
1 | find_package(Qt5 REQUIRED NO_MODULE COMPONENTS QuickTest Network Quick) | 1 | find_package(Qt5 REQUIRED NO_MODULE COMPONENTS QuickTest Network Quick) |
2 | find_package(Sink CONFIG REQUIRED) | 2 | find_package(Sink CONFIG REQUIRED) |
3 | find_package(KAsync CONFIG REQUIRED) | 3 | find_package(KAsync CONFIG REQUIRED) |
4 | find_package(KF5CalendarCore CONFIG REQUIRED) | ||
4 | 5 | ||
5 | add_executable(kubetestrunner kubetestrunner.cpp) | 6 | add_executable(kubetestrunner kubetestrunner.cpp) |
6 | target_link_libraries(kubetestrunner | 7 | target_link_libraries(kubetestrunner |
@@ -15,5 +16,6 @@ install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/test) | |||
15 | add_library(testplugin SHARED testplugin.cpp teststore.cpp) | 16 | add_library(testplugin SHARED testplugin.cpp teststore.cpp) |
16 | target_link_libraries(testplugin | 17 | target_link_libraries(testplugin |
17 | kubeframework | 18 | kubeframework |
19 | KF5::CalendarCore | ||
18 | ) | 20 | ) |
19 | install(TARGETS testplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/test) | 21 | install(TARGETS testplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/test) |