diff options
Diffstat (limited to 'framework/theme/CMakeLists.txt')
-rw-r--r-- | framework/theme/CMakeLists.txt | 14 |
1 files changed, 14 insertions, 0 deletions
diff --git a/framework/theme/CMakeLists.txt b/framework/theme/CMakeLists.txt new file mode 100644 index 00000000..319e3d39 --- /dev/null +++ b/framework/theme/CMakeLists.txt | |||
@@ -0,0 +1,14 @@ | |||
1 | set(themeplugin_SRCS | ||
2 | themeplugin.cpp | ||
3 | colorpalette.cpp | ||
4 | unit.cpp | ||
5 | ) | ||
6 | |||
7 | add_library(themeplugin SHARED ${themeplugin_SRCS}) | ||
8 | |||
9 | qt5_use_modules(themeplugin Core Quick Qml) | ||
10 | |||
11 | target_link_libraries(themeplugin) | ||
12 | |||
13 | install(TARGETS themeplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/theme) | ||
14 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/theme) | ||