diff options
Diffstat (limited to 'framework/src/CMakeLists.txt')
-rw-r--r-- | framework/src/CMakeLists.txt | 18 |
1 files changed, 9 insertions, 9 deletions
diff --git a/framework/src/CMakeLists.txt b/framework/src/CMakeLists.txt index 37cb9640..69b7a151 100644 --- a/framework/src/CMakeLists.txt +++ b/framework/src/CMakeLists.txt | |||
@@ -9,20 +9,14 @@ find_package(KF5Package CONFIG REQUIRED) | |||
9 | 9 | ||
10 | add_definitions("-Wall -std=c++0x -g") | 10 | add_definitions("-Wall -std=c++0x -g") |
11 | 11 | ||
12 | include_directories(. domain/mimetreeparser) | 12 | include_directories(. domain/mime/mimetreeparser) |
13 | 13 | ||
14 | set(SRCS | 14 | set(SRCS |
15 | frameworkplugin.cpp | 15 | frameworkplugin.cpp |
16 | settings/settings.cpp | 16 | settings/settings.cpp |
17 | domain/attachmentmodel.cpp | ||
18 | domain/maillistmodel.cpp | 17 | domain/maillistmodel.cpp |
19 | domain/folderlistmodel.cpp | 18 | domain/folderlistmodel.cpp |
20 | domain/objecttreesource.cpp | ||
21 | domain/stringhtmlwriter.cpp | ||
22 | domain/composercontroller.cpp | 19 | domain/composercontroller.cpp |
23 | domain/messageparser.cpp | ||
24 | domain/messageparser_new.cpp | ||
25 | domain/mailtemplates.cpp | ||
26 | domain/modeltest.cpp | 20 | domain/modeltest.cpp |
27 | domain/retriever.cpp | 21 | domain/retriever.cpp |
28 | domain/outboxmodel.cpp | 22 | domain/outboxmodel.cpp |
@@ -35,7 +29,13 @@ set(SRCS | |||
35 | domain/contactcontroller.cpp | 29 | domain/contactcontroller.cpp |
36 | domain/controller.cpp | 30 | domain/controller.cpp |
37 | domain/peoplemodel.cpp | 31 | domain/peoplemodel.cpp |
38 | domain/htmlutils.cpp | 32 | domain/mime/htmlutils.cpp |
33 | domain/mime/messageparser.cpp | ||
34 | domain/mime/messageparser_new.cpp | ||
35 | domain/mime/mailtemplates.cpp | ||
36 | domain/mime/attachmentmodel.cpp | ||
37 | domain/mime/objecttreesource.cpp | ||
38 | domain/mime/stringhtmlwriter.cpp | ||
39 | accounts/accountfactory.cpp | 39 | accounts/accountfactory.cpp |
40 | accounts/accountsmodel.cpp | 40 | accounts/accountsmodel.cpp |
41 | fabric.cpp | 41 | fabric.cpp |
@@ -47,6 +47,6 @@ qt5_use_modules(frameworkplugin Core Quick Qml WebEngineWidgets Test) | |||
47 | target_link_libraries(frameworkplugin sink mimetreeparser KF5::Codecs KF5::Package KAsync) | 47 | target_link_libraries(frameworkplugin sink mimetreeparser KF5::Codecs KF5::Package KAsync) |
48 | install(TARGETS frameworkplugin DESTINATION ${FRAMEWORK_INSTALL_DIR}) | 48 | install(TARGETS frameworkplugin DESTINATION ${FRAMEWORK_INSTALL_DIR}) |
49 | 49 | ||
50 | add_subdirectory(domain/mimetreeparser) | 50 | add_subdirectory(domain/mime/mimetreeparser) |
51 | 51 | ||
52 | feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES) | 52 | feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES) |