summaryrefslogtreecommitdiffstats
path: root/framework/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/src/CMakeLists.txt')
-rw-r--r--framework/src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/framework/src/CMakeLists.txt b/framework/src/CMakeLists.txt
index 44d58796..e975e61e 100644
--- a/framework/src/CMakeLists.txt
+++ b/framework/src/CMakeLists.txt
@@ -54,6 +54,11 @@ add_library(kubeframework SHARED
54 extensionmodel.cpp 54 extensionmodel.cpp
55 viewhighlighter.cpp 55 viewhighlighter.cpp
56 ) 56 )
57generate_export_header(kubeframework BASE_NAME Kube EXPORT_FILE_NAME kube_export.h)
58set_target_properties(kubeframework PROPERTIES
59 ENABLE_EXPORTS 1
60 WINDOWS_EXPORT_ALL_SYMBOLS 1
61)
57target_link_libraries(kubeframework 62target_link_libraries(kubeframework
58 sink 63 sink
59 kube_otp 64 kube_otp