summaryrefslogtreecommitdiffstats
path: root/framework/notifications/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/notifications/CMakeLists.txt')
-rw-r--r--framework/notifications/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/framework/notifications/CMakeLists.txt b/framework/notifications/CMakeLists.txt
new file mode 100644
index 00000000..ec2f52c2
--- /dev/null
+++ b/framework/notifications/CMakeLists.txt
@@ -0,0 +1,12 @@
1set(SRCS
2 notificationplugin.cpp
3 notificationhandler.cpp
4)
5
6add_library(notificationplugin SHARED ${SRCS})
7
8target_link_libraries(notificationplugin sink)
9qt5_use_modules(notificationplugin Core Quick Qml)
10
11install(TARGETS notificationplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/notifications)
12install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/notifications)