summaryrefslogtreecommitdiffstats
path: root/framework/mail/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/mail/CMakeLists.txt')
-rw-r--r--framework/mail/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/framework/mail/CMakeLists.txt b/framework/mail/CMakeLists.txt
index 13788cfa..94d15f4c 100644
--- a/framework/mail/CMakeLists.txt
+++ b/framework/mail/CMakeLists.txt
@@ -6,19 +6,25 @@ set(mailplugin_SRCS
6 folderlistmodel.cpp 6 folderlistmodel.cpp
7 folderlistcontroller.cpp 7 folderlistcontroller.cpp
8 actions/sinkactions.cpp 8 actions/sinkactions.cpp
9 actions/mailactions.cpp
9 objecttreesource.cpp 10 objecttreesource.cpp
10 stringhtmlwriter.cpp 11 stringhtmlwriter.cpp
11 csshelper.cpp 12 csshelper.cpp
12 composer.cpp 13 composer.cpp
13 messageparser.cpp 14 messageparser.cpp
15 mailtransport.cpp
14) 16)
15add_definitions(-DMAIL_DATA_DIR="${CMAKE_CURRENT_SOURCE_DIR}/data") 17add_definitions(-DMAIL_DATA_DIR="${CMAKE_CURRENT_SOURCE_DIR}/data")
16 18
19find_package(CURL 7.20.0 REQUIRED)
20
21include_directories(${CURL_INCLUDE_DIRS})
22
17add_library(mailplugin SHARED ${mailplugin_SRCS}) 23add_library(mailplugin SHARED ${mailplugin_SRCS})
18 24
19qt5_use_modules(mailplugin Core Quick Qml) 25qt5_use_modules(mailplugin Core Quick Qml)
20 26
21target_link_libraries(mailplugin actionplugin sink KF5::Otp) 27target_link_libraries(mailplugin actionplugin sink KF5::Otp ${CURL_LIBRARIES})
22 28
23install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail) 29install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail)
24install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail) 30install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail)