summaryrefslogtreecommitdiffstats
path: root/framework/mail/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/mail/CMakeLists.txt')
-rw-r--r--framework/mail/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/framework/mail/CMakeLists.txt b/framework/mail/CMakeLists.txt
index 0327d457..c57ac1fe 100644
--- a/framework/mail/CMakeLists.txt
+++ b/framework/mail/CMakeLists.txt
@@ -2,12 +2,15 @@ set(mailplugin_SRCS
2 mailplugin.cpp 2 mailplugin.cpp
3 maillistcontroller.cpp 3 maillistcontroller.cpp
4 maillistmodel.cpp 4 maillistmodel.cpp
5 singlemailcontroller.cpp
5) 6)
6 7
7add_library(mailplugin SHARED ${mailplugin_SRCS}) 8add_library(mailplugin SHARED ${mailplugin_SRCS})
8 9
9qt5_use_modules(mailplugin Core Quick Qml) 10qt5_use_modules(mailplugin Core Quick Qml)
11
10target_link_libraries(mailplugin /work/install/lib64/libakonadi2common.so) 12target_link_libraries(mailplugin /work/install/lib64/libakonadi2common.so)
13#target_link_libraries(mailplugin /home/mike/projects/_install/lib/x86_64-linux-gnu/libakonadi2common.so)
11 14
12install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/mail) 15install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/mail)
13install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/mail) \ No newline at end of file 16install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/mail) \ No newline at end of file