summaryrefslogtreecommitdiffstats
path: root/framework/mail/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/mail/CMakeLists.txt')
-rw-r--r--framework/mail/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/framework/mail/CMakeLists.txt b/framework/mail/CMakeLists.txt
new file mode 100644
index 00000000..100b9d9e
--- /dev/null
+++ b/framework/mail/CMakeLists.txt
@@ -0,0 +1,12 @@
1set(mailplugin_SRCS
2 mailplugin.cpp
3 maillistcontroller.cpp
4 maillistmodel.cpp
5)
6
7add_library(mailplugin SHARED ${mailplugin_SRCS})
8
9qt5_use_modules(mailplugin Core Quick Qml)
10
11install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/mail)
12install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/mail) \ No newline at end of file