summaryrefslogtreecommitdiffstats
path: root/framework/domain/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r--framework/domain/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt
index 804b3ccb..55bc2f24 100644
--- a/framework/domain/CMakeLists.txt
+++ b/framework/domain/CMakeLists.txt
@@ -7,6 +7,8 @@ set(mailplugin_SRCS
7 stringhtmlwriter.cpp 7 stringhtmlwriter.cpp
8 composercontroller.cpp 8 composercontroller.cpp
9 messageparser.cpp 9 messageparser.cpp
10 messageparser_new.cpp
11 messageparser_old.cpp
10 mailtemplates.cpp 12 mailtemplates.cpp
11 retriever.cpp 13 retriever.cpp
12 accountfactory.cpp 14 accountfactory.cpp
@@ -21,9 +23,11 @@ find_package(KF5 REQUIRED COMPONENTS Package)
21add_library(mailplugin SHARED ${mailplugin_SRCS}) 23add_library(mailplugin SHARED ${mailplugin_SRCS})
22 24
23qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) 25qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets)
24target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) 26target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes)
25 27
26add_subdirectory(actions/tests) 28add_subdirectory(actions/tests)
27 29
28install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) 30install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain)
29install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) 31install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain)
32
33add_subdirectory(mimetreeparser) \ No newline at end of file