diff options
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r-- | framework/domain/CMakeLists.txt | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt index 804b3ccb..55bc2f24 100644 --- a/framework/domain/CMakeLists.txt +++ b/framework/domain/CMakeLists.txt | |||
@@ -7,6 +7,8 @@ set(mailplugin_SRCS | |||
7 | stringhtmlwriter.cpp | 7 | stringhtmlwriter.cpp |
8 | composercontroller.cpp | 8 | composercontroller.cpp |
9 | messageparser.cpp | 9 | messageparser.cpp |
10 | messageparser_new.cpp | ||
11 | messageparser_old.cpp | ||
10 | mailtemplates.cpp | 12 | mailtemplates.cpp |
11 | retriever.cpp | 13 | retriever.cpp |
12 | accountfactory.cpp | 14 | accountfactory.cpp |
@@ -21,9 +23,11 @@ find_package(KF5 REQUIRED COMPONENTS Package) | |||
21 | add_library(mailplugin SHARED ${mailplugin_SRCS}) | 23 | add_library(mailplugin SHARED ${mailplugin_SRCS}) |
22 | 24 | ||
23 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) | 25 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) |
24 | target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) | 26 | target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) |
25 | 27 | ||
26 | add_subdirectory(actions/tests) | 28 | add_subdirectory(actions/tests) |
27 | 29 | ||
28 | install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) | 30 | install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) |
29 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) | 31 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) |
32 | |||
33 | add_subdirectory(mimetreeparser) \ No newline at end of file | ||