summaryrefslogtreecommitdiffstats
path: root/framework/domain/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r--framework/domain/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt
deleted file mode 100644
index e1482301..00000000
--- a/framework/domain/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
1set(mailplugin_SRCS
2 attachmentmodel.cpp
3 mailplugin.cpp
4 maillistmodel.cpp
5 folderlistmodel.cpp
6 actions/sinkactions.cpp
7 objecttreesource.cpp
8 stringhtmlwriter.cpp
9 composercontroller.cpp
10 messageparser.cpp
11 messageparser_new.cpp
12 messageparser_old.cpp
13 mailtemplates.cpp
14 modeltest.cpp
15 retriever.cpp
16 outboxmodel.cpp
17 identitiesmodel.cpp
18 recepientautocompletionmodel.cpp
19 settings/accountsettings.cpp
20 selector.cpp
21 completer.cpp
22 controller.cpp
23 outboxcontroller.cpp
24 mailcontroller.cpp
25 foldercontroller.cpp
26 mouseproxy.cpp
27 contactcontroller.cpp
28 peoplemodel.cpp
29)
30find_package(KF5 REQUIRED COMPONENTS Package)
31
32add_library(mailplugin SHARED ${mailplugin_SRCS})
33
34qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets Test)
35target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KAsync)
36
37
38install(TARGETS mailplugin DESTINATION ${FRAMEWORK_INSTALL_DIR})
39
40add_subdirectory(actions/tests)
41add_subdirectory(mimetreeparser)