summaryrefslogtreecommitdiffstats
path: root/framework/domain/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r--framework/domain/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt
index ea293655..07f01367 100644
--- a/framework/domain/CMakeLists.txt
+++ b/framework/domain/CMakeLists.txt
@@ -20,9 +20,11 @@ find_package(KF5 REQUIRED COMPONENTS Package)
20add_library(mailplugin SHARED ${mailplugin_SRCS}) 20add_library(mailplugin SHARED ${mailplugin_SRCS})
21 21
22qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) 22qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets)
23target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) 23target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes)
24 24
25add_subdirectory(actions/tests) 25add_subdirectory(actions/tests)
26 26
27install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) 27install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain)
28install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) 28install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain)
29
30add_subdirectory(mimetreeparser) \ No newline at end of file