summaryrefslogtreecommitdiffstats
path: root/framework/domain/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r--framework/domain/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt
index 804b3ccb..a31bb016 100644
--- a/framework/domain/CMakeLists.txt
+++ b/framework/domain/CMakeLists.txt
@@ -7,7 +7,10 @@ set(mailplugin_SRCS
7 stringhtmlwriter.cpp 7 stringhtmlwriter.cpp
8 composercontroller.cpp 8 composercontroller.cpp
9 messageparser.cpp 9 messageparser.cpp
10 messageparser_new.cpp
11 messageparser_old.cpp
10 mailtemplates.cpp 12 mailtemplates.cpp
13 modeltest.cpp
11 retriever.cpp 14 retriever.cpp
12 accountfactory.cpp 15 accountfactory.cpp
13 accountscontroller.cpp 16 accountscontroller.cpp
@@ -20,10 +23,12 @@ find_package(KF5 REQUIRED COMPONENTS Package)
20 23
21add_library(mailplugin SHARED ${mailplugin_SRCS}) 24add_library(mailplugin SHARED ${mailplugin_SRCS})
22 25
23qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) 26qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets Test)
24target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) 27target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes)
25 28
26add_subdirectory(actions/tests) 29add_subdirectory(actions/tests)
27 30
28install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) 31install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain)
29install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) 32install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain)
33
34add_subdirectory(mimetreeparser)