diff options
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r-- | framework/domain/CMakeLists.txt | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt new file mode 100644 index 00000000..822b2981 --- /dev/null +++ b/framework/domain/CMakeLists.txt | |||
@@ -0,0 +1,32 @@ | |||
1 | set(mailplugin_SRCS | ||
2 | mailplugin.cpp | ||
3 | maillistcontroller.cpp | ||
4 | maillistmodel.cpp | ||
5 | singlemailcontroller.cpp | ||
6 | folderlistmodel.cpp | ||
7 | folderlistcontroller.cpp | ||
8 | actions/sinkactions.cpp | ||
9 | actions/mailactions.cpp | ||
10 | objecttreesource.cpp | ||
11 | stringhtmlwriter.cpp | ||
12 | csshelper.cpp | ||
13 | composer.cpp | ||
14 | messageparser.cpp | ||
15 | mailtransport.cpp | ||
16 | mailtemplates.cpp | ||
17 | retriever.cpp | ||
18 | ) | ||
19 | add_definitions(-DMAIL_DATA_DIR="${CMAKE_CURRENT_SOURCE_DIR}/data") | ||
20 | |||
21 | find_package(CURL 7.20.0 REQUIRED) | ||
22 | |||
23 | include_directories(${CURL_INCLUDE_DIRS}) | ||
24 | |||
25 | add_library(mailplugin SHARED ${mailplugin_SRCS}) | ||
26 | |||
27 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) | ||
28 | |||
29 | target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::Otp KF5::Codecs ${CURL_LIBRARIES}) | ||
30 | |||
31 | install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail) | ||
32 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail) | ||