diff options
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r-- | framework/domain/CMakeLists.txt | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt index 55bc2f24..a31bb016 100644 --- a/framework/domain/CMakeLists.txt +++ b/framework/domain/CMakeLists.txt | |||
@@ -10,6 +10,7 @@ set(mailplugin_SRCS | |||
10 | messageparser_new.cpp | 10 | messageparser_new.cpp |
11 | messageparser_old.cpp | 11 | messageparser_old.cpp |
12 | mailtemplates.cpp | 12 | mailtemplates.cpp |
13 | modeltest.cpp | ||
13 | retriever.cpp | 14 | retriever.cpp |
14 | accountfactory.cpp | 15 | accountfactory.cpp |
15 | accountscontroller.cpp | 16 | accountscontroller.cpp |
@@ -22,7 +23,7 @@ find_package(KF5 REQUIRED COMPONENTS Package) | |||
22 | 23 | ||
23 | add_library(mailplugin SHARED ${mailplugin_SRCS}) | 24 | add_library(mailplugin SHARED ${mailplugin_SRCS}) |
24 | 25 | ||
25 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) | 26 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets Test) |
26 | target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) | 27 | target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) |
27 | 28 | ||
28 | add_subdirectory(actions/tests) | 29 | add_subdirectory(actions/tests) |
@@ -30,4 +31,4 @@ add_subdirectory(actions/tests) | |||
30 | install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) | 31 | install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) |
31 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) | 32 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) |
32 | 33 | ||
33 | add_subdirectory(mimetreeparser) \ No newline at end of file | 34 | add_subdirectory(mimetreeparser) |