summaryrefslogtreecommitdiffstats
path: root/framework/actions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/actions/CMakeLists.txt')
-rw-r--r--framework/actions/CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/framework/actions/CMakeLists.txt b/framework/actions/CMakeLists.txt
deleted file mode 100644
index 72dd9fcd..00000000
--- a/framework/actions/CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
1set(SRCS
2 actionplugin.cpp
3 action.cpp
4 actionhandler.cpp
5 actionbroker.cpp
6 actionresult.cpp
7 context.cpp
8)
9
10add_library(actionplugin SHARED ${SRCS})
11
12target_link_libraries(actionplugin KAsync sink)
13qt5_use_modules(actionplugin Core Quick Qml)
14
15install(TARGETS actionplugin DESTINATION ${FRAMEWORK_INSTALL_DIR})
16
17add_subdirectory(tests)