summaryrefslogtreecommitdiffstats
path: root/framework/accounts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/accounts/CMakeLists.txt')
-rw-r--r--framework/accounts/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/framework/accounts/CMakeLists.txt b/framework/accounts/CMakeLists.txt
new file mode 100644
index 00000000..bccafd77
--- /dev/null
+++ b/framework/accounts/CMakeLists.txt
@@ -0,0 +1,13 @@
1set(accountsplugin_SRCS
2 accountsplugin.cpp
3 accountfactory.cpp
4 accountsmodel.cpp
5)
6
7add_library(accountsplugin SHARED ${accountsplugin_SRCS})
8
9qt5_use_modules(accountsplugin Core Quick Qml)
10target_link_libraries(accountsplugin sink mailplugin)
11
12install(TARGETS accountsplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/accounts)
13install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/accounts)